By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,045 Members | 1,743 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,045 IT Pros & Developers. It's quick & easy.

OLE Images and Forms

P: n/a
After getting around a problem with the Norton utilities, I have finally
been able to get .jpg images linked to my table. When I try to display the
images using a form, the form presents icons which, when selected, will then
display the image.

Is it possible to get the actual images (they are small thumbnails) to
appear on the form without having to deal with this icon?

George
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
This may give some ideas:
I had a similar situation which is working well in
Access. I scanned JPEGs of all my products and opened a field in my
product table called ProductPicture. The value of each field
corresponds to
an address in another folder on my server that holds all the JPEGS.
My address field for say my product 7961776 is stored on a Linux
server
having a common folder and a sub-folder named
productJPGs. So my field in my access table has this value to look up:

\\LinuxMain\Common\productJPGs\7961776.jpg

In my report, which can be printed as a product spec
sheet or emailed, the formatting routine (in the code for the report)
links the jpeg at the time of printing or emailing. It gets its value
from the form where I choose a product from a combo box.

'on format jpeg is referenced
Private Sub Detail_Format(Cancel As Integer,
FormatCount As Integer)

On Error Resume Next
Me![ProductImage].Picture =
[Forms]![ProdDispScreen]![ProdID]

End Sub
My print button on my ProdDispScreen form has the
following code:

Private Sub printSpecs_Click()
'Prints Product Specifications of ProdID shown in ProdDispScreen.
On Error GoTo Err_printSpecs_Click
Dim stDocName As String
stDocName = "TagSpecRep"
DoCmd.OpenReport stDocName, acPreview,
"TagSpecFilter"
DoCmd.RunCommand acCmdZoom50
Exit_printSpecs_Click:
Exit Sub
Err_printSpecs_Click:
MsgBox err.Description
Resume Exit_printSpecs_Click
End Sub

the "TagSpecFilter" is a query that simply tells it to
print a report
only for the displayed record (product). SQL:

SELECT DISTINCTROW ProdID.*
FROM VFProducts
WHERE
(((Products.ProdID)=[Forms]![ProdDispScreen]![ProdID]));

In summary, placing all the actual jpeg files in a separate folder
from my actual Access Application improves the performance. I
originally placed the jpegs themselves into my database, but the
loading time and size of my app was unbelievable. Hope this helps a
little!

hth

Brian
"Starwood" <st******@one.net> wrote in message news:<vm************@corp.supernews.com>...
After getting around a problem with the Norton utilities, I have finally
been able to get .jpg images linked to my table. When I try to display the
images using a form, the form presents icons which, when selected, will then
display the image.

Is it possible to get the actual images (they are small thumbnails) to
appear on the form without having to deal with this icon?

George

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.