469,926 Members | 1,812 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,926 developers. It's quick & easy.

Query shows no data in data view

I have an ACCESS db from a DEXA machine (bone scanner). The data is in
seperate tables and I want to link them so that I can query and create one
table with all the data I need from the seperate tables. When I try to
create a query with multiple tables in design view, if I run it to see the
data view, only the names of the columns appear, but no data from the
multiple tables that I have queried shows. If I bring only 1 table into
design view and query it, I have no problem. Thansk for any suggestions.

Nov 12 '05 #1
4 4168
I suppose there is just no data that matches your query

Have you joined the right fields? Are the join-fields the same type ?
Do you use INNER Joins? Perhaps you could try OUTER Joins

--
Hope this helps
Arno R
<sw*********@yahoo.com> schreef in bericht news:bj**********@mozo.cc.purdue.edu...
I have an ACCESS db from a DEXA machine (bone scanner). The data is in
seperate tables and I want to link them so that I can query and create one
table with all the data I need from the seperate tables. When I try to
create a query with multiple tables in design view, if I run it to see the
data view, only the names of the columns appear, but no data from the
multiple tables that I have queried shows. If I bring only 1 table into
design view and query it, I have no problem. Thansk for any suggestions.

Nov 12 '05 #2
Post the SQL for your query.
On Wed, 10 Sep 2003 10:36:34 -0500, <sw*********@yahoo.com> wrote:
I have an ACCESS db from a DEXA machine (bone scanner). The data is in
seperate tables and I want to link them so that I can query and create one
table with all the data I need from the seperate tables. When I try to
create a query with multiple tables in design view, if I run it to see the
data view, only the names of the columns appear, but no data from the
multiple tables that I have queried shows. If I bring only 1 table into
design view and query it, I have no problem. Thansk for any suggestions.


Nov 12 '05 #3
<sw*********@yahoo.com> wrote in message news:<bj**********@mozo.cc.purdue.edu>...
I have an ACCESS db from a DEXA machine (bone scanner). The data is in
seperate tables and I want to link them so that I can query and create one
table with all the data I need from the seperate tables. When I try to
create a query with multiple tables in design view, if I run it to see the
data view, only the names of the columns appear, but no data from the
multiple tables that I have queried shows. If I bring only 1 table into
design view and query it, I have no problem. Thansk for any suggestions.


sounds like your tables are joined on a field with no values in
common, so all of your records are filtered out. If you want to test
it, outer join the tables by right-clicking on the join line and
selecting either a left or right join (2 or 3) instead of option 1.
Nov 12 '05 #4
I figured it out. I was using the key from the one to many table instead of
using it first from the many to one table, if that makes sense.
<sw*********@yahoo.com> wrote in message
news:bj**********@mozo.cc.purdue.edu...
I have an ACCESS db from a DEXA machine (bone scanner). The data is in
seperate tables and I want to link them so that I can query and create one
table with all the data I need from the seperate tables. When I try to
create a query with multiple tables in design view, if I run it to see the
data view, only the names of the columns appear, but no data from the
multiple tables that I have queried shows. If I bring only 1 table into
design view and query it, I have no problem. Thansk for any suggestions.

Nov 12 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Peter Bailey | last post: by
5 posts views Thread by Andy Davis | last post: by
5 posts views Thread by Merennulli | last post: by
2 posts views Thread by existential.philosophy | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.