By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,034 Members | 1,672 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,034 IT Pros & Developers. It's quick & easy.

Query displays

P: n/a
I discovered a weird behaviour regarding a query and a combobox based on
that query.

3 tables:

Food:
Food_ID number (autonumber - primary key)
Number number
Fruit_ID combobox

1, 100, Banana
2, 75, Apple
...

Fruit:
Fruit_ID number (autonumber - primary key)
Name text
Color_ID combobox

1, Banana, yellow
2, Apple, green
...

Color:
Color_ID number (autonumber - primary key)
Color text

1, yellow
2, green
3, brown

The combobox of Food: has an underlying query (3 columns).

Fruit_ID.Food (0 cm width)
Name.Fruit (5 cm width)
Color_ID.Fruit (2 cm width)

Now comes the interesting part; when I run the query, I get ...

1, Banana, yellow
2, Apple, green
...

However when I select the pop-up button on the right side of the
combobox of Food:, I get:

1, Banana, 1
2, Apple, 2

The Color_ID is not resolved for the combobox, while it is for the query.

How can I change this behaviour in order to make the Color appear as
well in the combobox instead of the Color_ID?

TIA

--
Georges Heinesch <vo**@geohei.lu>, Luxembourg
PGP RSA & DH/DSS public key on request and on public servers

Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.