473,698 Members | 2,295 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Treeview nodeClick doesn't fire when clicked

9 New Member
We are using the treeview common control in an MS Access form. I've encountered a situation with a user where when he clicks a node in the tree, the nodeclick() event does not fire, yet the tree is still fully navigable. He can open and close all the branches, but the background code that picks up the nodeclick() just doesn't fire. However we have buttons on the screen that, thru code, find the next node and "click" it through VBA. That works fine and the resulting nodeclick() code does fire in that case, just not when the user uses the mouse to click it.

I'm struggling for how to even begin troubleshooting this. It's one thing to have an error happen that I can trace thru, but when something doesn't happen and no event is triggered, how might I track down where the failure is? BTW, this is a Windows XP/Office 2007 PC.

BACKGROUND:
We were hit hard by the MS12-060 patch issue as documented in the following KB: http://support.microsoft.com/kb/2748410
We're still dealing with users that are opening the database for the first time since August and discover it won't work. In troubleshooting the problem, another administrator did "something" to the PC. Unfortunately I don't know what they did but I do know it had to do with the MSCOMCTL.OCX library, which is the exact same library the treeview comes from. I've confirmed the filesize/date and it is still the correct common controls library version. Otherwise the entire database is functional and working fine.

Any ideas?
Dec 12 '12 #1
13 9758
NeoPa
32,569 Recognized Expert Moderator MVP
Has the setting to trust add-ins been reset by any chance? A2007 makes security very complicated to manage sensibly, and this is one issue that might cause such symptoms.
Dec 12 '12 #2
argonautical
9 New Member
hmm, that's a good one to look for, thanks. I'll check so see if it is different on that PC than the others.
Dec 12 '12 #3
TheSmileyCoder
2,322 Recognized Expert Moderator Top Contributor
Try putting the following in a .bat file and run it from the users pc:
Expand|Select|Wrap|Line Numbers
  1. reg delete hkcr\typelib\{831FDD16-0C5C-11D2-A9FC-0000F8754DA1}\2.0 /f
  2.  
  3. if exist %systemroot%\SysWOW64\cscript.exe goto 64 
  4.  
  5. %systemroot%\system32\regsvr32 /u /s mscomctl.ocx 
  6.  
  7. %systemroot%\system32\regsvr32 /s mscomctl.ocx
  8.  
  9. exit
  10.  
  11.  
  12. :64 
  13.  
  14. %systemroot%\sysWOW64\regsvr32 /u /s mscomctl.ocx
  15.  
  16. %systemroot%\sysWOW64\regsvr32 /s mscomctl.ocx
  17.  
  18. exit
I have also attached the file (rename it from .txt to .bat)
Attached Files
File Type: txt Fixit.txt (357 Bytes, 852 views)
Dec 12 '12 #4
TheSmileyCoder
2,322 Recognized Expert Moderator Top Contributor
I have had many users have the problem with the MS patch, and one thing I noticed is that it seems to hit in very in-consitent ways. On some PCs the treeview was partly functional, on others no funtionality at all, the db wouldn't even open.
Dec 12 '12 #5
argonautical
9 New Member
Thanks TheSmileyCoder. We've experienced and seen the exact same behavior. I has already removed the problematic registry key and registered and unregistered the library. That's the process that has worked consistently (luckily) for over a hundred users, and as soon as I did that, this guy's database did stop toss out errors. However this is the first time we've seen that the errors stopped, yet part of the treeview control just plain doesn't work. Like I said, everything appears to be working fine and as designed except for the nodeclick. Having a tough time running it down.

NeoPa, I did confirm the add-in trust settings and they are still set the same as mine (yet my PC doesn't exhibit the behavior), so I think it must be something else.

Unfortunately I'm not allowed to have admin access to the PC because we're in a huge enterprise environment. I'm strongly suspicious that an administrator did something on their own prior to me giving them the instructions for how to fix the MS12-060 patch issue. So once we had them patch it correctly the known errors went away but this missing nodeclick event remains.
Dec 13 '12 #6
TheSmileyCoder
2,322 Recognized Expert Moderator Top Contributor
OK
I presume you have allready tried hitting up the user with a new frontend?

Access 2010 has a new tab specific for Active x security settings. I don't know if Access 2007 has this as well, and I have never had the need to look in it, but may be worth a shot.
Dec 13 '12 #7
argonautical
9 New Member
Yep, put an entirely new copy of the database on their PC and that copy exhibits the same behavior. And if I move their problematic DB to my PC it doesn't act that way. So I'm confident it is isolated to his PC and is not something internal to that actual MDB file.

Thanks for the pointer about ActiveX security. From what I know that's all controlled via group policy and not directly in Access so it'll take some time for me to get someone to do that for me. But have you ever seen a setting like that only disable part of a control's behavior? The treeview control works perfectly in every other use, just not the nodeclick. I would think that if it was a security setting being disabled, it'd be breaking the whole thing rather than just one event. Does that sound logical or am I overthinking it?
Dec 13 '12 #8
TheSmileyCoder
2,322 Recognized Expert Moderator Top Contributor
It does sound logical. But just like you I am perplexed, and to be honest shooting in the dark. Do you have other treeview events that work as intended when triggered by the user and not by code?

Is it both keyboard and mouse input that fails to trigger the nodeclick event? Can the mousedown/mouseup be triggered?
Dec 13 '12 #9
argonautical
9 New Member
Thank you! Yes, other events do work fine from the GUI side, but I had my head down so much I didn't think to put in new event triggers to confirm all events are actually showing up in VBA. I'll work in that direction and see what I can find. Thanks again for the suggestion, hopefully that'll pan out.
Dec 13 '12 #10

Sign in to post your reply or Sign up for a free account.

Similar topics

0
342
by: Alex Stevens | last post by:
Hi, I have a page in which I've added code to the Page_Load event. I send the url to a user in an email, and they click on it to activate an account. I put a breakpoint on the first execuable line of code in the page load event. The breakpoint works fine when linked to from another page on the site, and
14
23247
by: xxbmichae1 | last post by:
I have a <select> object that i've set up an onchange event that fires in IE fine when I use the cursor up and down in the list, but If I use the cursor up and down in Firefox the event doesn't seem to fire until I've left the field....If i use the mouse all is fine, only when using the cursor keys does it not fire the onchange event in FF. Thanks for any help in advance.
2
1993
by: Peter Afonin | last post by:
Hello: I'm deleteing data using Datagrid, then rebind it. For some reason ItemDataBound event doesn't fire after DeleteCommand. Why is this? Is it by design, or I'm missing something? I have some important calculations in ItemDataBound event. My code for DeleteCommand is below. I would appreciate your help very much. Private Sub dgData_DeleteCommand(ByVal source As Object, ByVal e As
23
5368
by: wylbur37 | last post by:
I'm running an Apache server on my own computer (Windows XP Pro). I wrote a simple PHP script (called test3.php) that I'm running by putting the following URL in the address bar of the browser (Firefox) .... http://localhost/test3.php The script generates the following link using the echo statement ...
0
1884
by: MalingreM | last post by:
Hi, I'm quite new to sql2005, and I've the following problem. When I insert records in table Data one by one, the insert/update trigger fires correctly, but: when i insert multiple records at once; it doesn't I use a syntax like this: INSERT INTO Data (ProcID, TaskID, , , , IsAddrField, UsedInSubProcID) SELECT @ProcID, @TaskID, , 0 ,, IsAddrField, UsedInSubProcID FROM Fields WHERE ProcID = @ProcID Please help? Maarten
1
1282
by: km7kumar | last post by:
Any ideas? thanks /kmk
0
8674
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
9028
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
8895
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
7728
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
4369
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
0
4619
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
3046
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
2330
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
2001
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.