473,837 Members | 1,931 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

"module not fount" problem

Hello there,

This is the case:

the mde I made works alright on my machine, but there is a small problem
when I installed it on a user's machine (His machine's OS is Windows XP Pro
and it has a Access 2k Runtime, my machine is in XP Pro and Access 2k): when
I try to close a form use "Alt+C" key, there is a error saying "module not
found" (It is Ok if I click the close_form sign "X" on the up right corner
of the form). This problem is only with one form, and this is the only error
I get, otherwise the mde seems to work very well.

I really don't understand this. Did I miss any update or service pack. Any
help will be very much appreciated. Thank you.

Paul
Nov 13 '05 #1
13 5819
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:oH******** ***********@new s.chello.at...
the mde I made works alright on my machine, but there is a small problem
when I installed it on a user's machine (His machine's OS is Windows XP
Pro
and it has a Access 2k Runtime, my machine is in XP Pro and Access 2k):
when
I try to close a form use "Alt+C" key, there is a error saying "module not
found" (It is Ok if I click the close_form sign "X" on the up right corner
of the form). This problem is only with one form, and this is the only
error
I get, otherwise the mde seems to work very well.


1 - Try making a copy of the form (Copy + Paste),
Renemae the original one to xxx_Old
Rename the new one to xxx.
Then you are using the new one

OR

2 - Create a new form
Select all object from the original form
and paste them to the new one.
Do the same with all code (events, class module)

I happened many times to solve this way
"misterious behaviors" with forms and reports.

Bruno
Nov 13 '05 #2
Bruno,

Thank you very much. BUt I am not as lucky as you. I was not allowed to
rename the new form....

I am still trying.

It happened recently many times.

This time it happened again when I deleted a form by mistake (and you can
not undo...) then when I tried to rebuild the form, it happened the
mysterious behavior of Access....

I am trying already 2 hours.

Paul

"Bruno Campanini" <br************ ****@tin.it> 写入消息新闻
:hq************ *********@news3 .tin.it...
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:oH******** ***********@new s.chello.at...
the mde I made works alright on my machine, but there is a small problem
when I installed it on a user's machine (His machine's OS is Windows XP
Pro
and it has a Access 2k Runtime, my machine is in XP Pro and Access 2k):
when
I try to close a form use "Alt+C" key, there is a error saying "module not found" (It is Ok if I click the close_form sign "X" on the up right corner of the form). This problem is only with one form, and this is the only
error
I get, otherwise the mde seems to work very well.


1 - Try making a copy of the form (Copy + Paste),
Renemae the original one to xxx_Old
Rename the new one to xxx.
Then you are using the new one

OR

2 - Create a new form
Select all object from the original form
and paste them to the new one.
Do the same with all code (events, class module)

I happened many times to solve this way
"misterious behaviors" with forms and reports.

Bruno

Nov 13 '05 #3
when I tried to build a new form with the same name of the form that I
deleted by mistake, there appears a error:

Failed when build Visual Basic module “│”

If database is on a net drive, please check your net connection, then try
again.

who knows what is the problem? Please help.

Paul


"Paul T. RONG" <et***@hotmail. com> 写入消息新闻
:BJ************ *******@news.ch ello.at...
Bruno,

Thank you very much. BUt I am not as lucky as you. I was not allowed to
rename the new form....

I am still trying.

It happened recently many times.

This time it happened again when I deleted a form by mistake (and you can
not undo...) then when I tried to rebuild the form, it happened the
mysterious behavior of Access....

I am trying already 2 hours.

Paul

"Bruno Campanini" <br************ ****@tin.it> 写入消息新闻
:hq************ *********@news3 .tin.it...
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:oH******** ***********@new s.chello.at...
the mde I made works alright on my machine, but there is a small problem when I installed it on a user's machine (His machine's OS is Windows XP Pro
and it has a Access 2k Runtime, my machine is in XP Pro and Access 2k): when
I try to close a form use "Alt+C" key, there is a error saying "module not found" (It is Ok if I click the close_form sign "X" on the up right corner of the form). This problem is only with one form, and this is the only
error
I get, otherwise the mde seems to work very well.


1 - Try making a copy of the form (Copy + Paste),
Renemae the original one to xxx_Old
Rename the new one to xxx.
Then you are using the new one

OR

2 - Create a new form
Select all object from the original form
and paste them to the new one.
Do the same with all code (events, class module)

I happened many times to solve this way
"misterious behaviors" with forms and reports.

Bruno


Nov 13 '05 #4
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:O9******** ***********@new s.chello.at...
when I tried to build a new form with the same name of the form that I
deleted by mistake, there appears a error:

Failed when build Visual Basic module “│”

If database is on a net drive, please check your net connection, then try
again.

who knows what is the problem? Please help.

Paul


Try creating a new database and import anything
from the old one.
When importing tables don't forget to check
"Import /Export Specs" in Options of
Import Dialog Box.

Bruno
Nov 13 '05 #5
Bruno:

good idea!

question: Why should I check the "Import/Export Specs", I saw that option,
but why?

I will try, but tomorrow... thanks a million!

Paul


"Bruno Campanini" <br************ ****@tin.it> 写入消息新闻
:Tt************ *********@news3 .tin.it...
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:O9******** ***********@new s.chello.at...
when I tried to build a new form with the same name of the form that I
deleted by mistake, there appears a error:

Failed when build Visual Basic module “│”

If database is on a net drive, please check your net connection, then try again.

who knows what is the problem? Please help.

Paul


Try creating a new database and import anything
from the old one.
When importing tables don't forget to check
"Import /Export Specs" in Options of
Import Dialog Box.

Bruno

Nov 13 '05 #6
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:R0******** ***********@new s.chello.at...
Bruno:

good idea!

question: Why should I check the "Import/Export Specs", I saw that option,
but why?

I will try, but tomorrow... thanks a million!

Paul


When you import/export Text or Spreadsheet in/from your
database Access gives you the chance to save those
specifications.
But when you import all objects from a database that
doesn't include those specifications unless you check
"Import/Export Specs".
It's a good idea always to check that item: in case
there are no specs to import you receive a message
saying there are no specs to import.

Good luck for tomorrow.
Bruno
Nov 13 '05 #7
Bruno,

it is a pity that I did not solve the problem. Very Weird.

Maybe after this experience I will give up Access.

I am searching answers through the cdma news group.

But it works perfectly in Access XP.

The Module not found problem only appears in Access 2K.

Thanks for support,

Paul
"Bruno Campanini" <br************ ****@tin.it> 写入消息新闻
:Oq************ *********@news3 .tin.it...
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:R0******** ***********@new s.chello.at...
Bruno:

good idea!

question: Why should I check the "Import/Export Specs", I saw that option, but why?

I will try, but tomorrow... thanks a million!

Paul


When you import/export Text or Spreadsheet in/from your
database Access gives you the chance to save those
specifications.
But when you import all objects from a database that
doesn't include those specifications unless you check
"Import/Export Specs".
It's a good idea always to check that item: in case
there are no specs to import you receive a message
saying there are no specs to import.

Good luck for tomorrow.
Bruno

Nov 13 '05 #8
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:SW******** ***********@new s.chello.at...

I think you sure tried to compile your file under
Access 2000.
If not try now.
Should you have any error message with Debug
you know where to look at.

Don't give up with Access, it's a great drug to
become crazy!!!

I'm so curious I'm asking to send me your file.
Shouldn't it contain any secret items, of course.

Bruno
Nov 13 '05 #9
Bruno,

it is solved.

after uncheck two references (one is MS Calendar Control 9.0 and the other
is MS ActiveX Data Objects 2.1) the problem mysteriously disappeared.

but who can explain to me why?

i can only remember that I tried to use the MS Calendar Control in one form
but later i gave it up, but didn't uncheck the reference very probably.

but anyway after today i decided to give up Access. Yes, I loved it, but it
also tortured me....there are many problems so unpredictable, maybe i am not
the database type.

i almost wanted to trouble somebody to send the mdb for a control but now it
is already done, not many secrets.

thanks for your concern,

greetings

Paul

from Bratislava, Slovakia

PS,

I like your expression of “it's a great drug to become crazy!!!”, but
there are so many great drugs for us to get crazy in this "crazy" world.
Probably I will pick my camera and start to shoot....that is also a great
drug for me.


"Bruno Campanini" <br************ ****@tin.it> 写入消息新闻
:v7************ **********@news 4.tin.it...
"Paul T. RONG" <et***@hotmail. com> wrote in message
news:SW******** ***********@new s.chello.at...

I think you sure tried to compile your file under
Access 2000.
If not try now.
Should you have any error message with Debug
you know where to look at.

Don't give up with Access, it's a great drug to
become crazy!!!

I'm so curious I'm asking to send me your file.
Shouldn't it contain any secret items, of course.

Bruno



Nov 13 '05 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

2
346
by: jon morgan | last post by:
Hi, Just how do you track down the location of an exception when all you get is a message saying "NullReferenceException occured in Unknown Module" ? It seems like the proverbial needle in a haystack when the debugger doesn't show you the line in your program that triggered the external error. Thanks for any help
2
3649
by: Paul T. RONG | last post by:
Hi, It is very strange. The mde works very well in Access XP but will get "Module not found" error when closing a form in Access 2k. I tried from yesterday evening to solve this prolem but in vain. Any help will be greatly appreciated. Thanks.
1
8005
by: Steve | last post by:
I get this message when I tried to make a .MDE of my database. "Compile error in hidden module: Form_frmPurchaseReq" I have been using this database for several months and just thought I would make a .MDE of it and this message came up. Help said, something about a protected module or something..... Could someone enlighten me on this problem?
5
3698
by: Bob | last post by:
Are they different names for the same concept ?
1
2603
by: Xiao Jianfeng | last post by:
Hello, In pymol I can use "from chempy import Atom" but "import chempy.Atom" doesn't work. It says,"ImportError: No module named Atom". What is going wrong ? Thanks
3
16531
by: David T. Ashley | last post by:
Hi, Red Hat Enterprise Linux 4.X. I'm writing command-line PHP scripts for the first time. I get the messages below. What do they mean? Are these operating system library modules, or something in PHP that I don't have? Do I need to install more Linux packages? Or adjust PHP in some way?
0
2064
by: Shehryar | last post by:
AOA, I urgently want to know the major difference between "Module" and a "Class Module". Plz, reply me as early as possible. Thanx!
3
5921
by: Mac Campbell | last post by:
For some unknown reason my mdb seemed to drop a module I had named "Utilities". I tried to copy the module back in from a backup copy and got the error message "<<MyProject>> is currently unable to rename the form, report, or module to 'Utilities' ... Close the database, reopen it, and try the rename operation again." This didn't work. It seemed that other modules could still be renamed normally, but this one - "Utilities" - could not. I could...
0
1716
by: Keith | last post by:
Hello, I am trying to create exectuables on inux using "pyinstaller". I am using pyinstaller-1.3, RHEL 4.4, Python 2.5. The executables fail to run. The problem returned is pertaining to "struct.py" not being able to find the module "_struct". struct.py is located under /usr/local/lib/python-2.5/, and there is a _struct.o (no _struct.py anywhere) located under /usr/local/lib/ python-2.5/lib-dynload.
0
9682
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
10877
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10570
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
0
9402
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project梡lanning, coding, testing, and deployment梬ithout human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
5670
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
0
5849
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
4474
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4041
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
3124
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.